TASVideos

Tool-assisted game movies
When human skills are just not enough

Bizhawk / Basic Bot

Basic Bot

TODO - Will make this more into a Tutorial Format with images and explanations of the various parts and any issues.

Basic Bot with TasStudio


(Link to video)

Notes

  1. -Check Memory Domain
  2. -Check Byte Length
  3. -Check that the Fitness Function (the Conditions) Make Sense.
  4. TasStudio can be used if you have BizHawk in the Recording Mode. Otherwise it will simply playback what is is in the TasStudio Piano Roll.
  5. Make Sure you select the Correct "Slot" Aka Save State. If you are not using TasStudio this is just a Save State Slot. For Tas Studios it is a Branch #. Ex:Slot = 0 would be Branch #0.
  6. The input is in percentages. For unlikely input I suggest very low percentages 0.1% to 0.2%.
  7. After finding a good series of input. Press STOP. Then Press "Play" in the "Best" group section. Then on the Branch select the Update button (the red recycle icon?). Then save.
  8. After finishing make sure to put Bizhawk back to the PlayBack Mode.
  9. Then you should clean up the input only leaving the minimum input to achieve the fast time.

Possible issues

  1. Conditions do not fire. Close and Restart Basic Bot. Just set it up anew.
  2. Conditions Always Are True. You probably have a bad condition. I had this with a bad Tie Condition. I was trying to use a timer but at the end it was always the same value and I was using Less Than Or Equal To for the first condition. It seems to evaluate the tie condition at the end number of frames.
  3. Ending Frame after Playback is after expected end. I had this happen a couple times. I would manually put the branch back a couple frames then run it. This seemed to let it work correctly.
  4. After Playback values are different. Look up at 3 should be a similar issue.
  5. Bot never finds a solution. If this is the case you have the number of frames it runs too high. This is a dumb bot and does not learn. The default 100 frames seems like a good amount to get good results.
  6. How to Switch Between Recording and Playback. My shortcut button is 'q'. You can view what yours is if you go to the menu "Configure Hotkeys" - Movie - "Toggle read-only".


Not sure but sometimes it really does seem like it does not actually save the correct main value or bot attempt. When I run it back it does not get near the reported Main Value. So kind of strange for sure. Seems buggy.


Combined RSS Feed
Bizhawk/BasicBot last edited by feos on 2019-07-14 09:05:23
Page info and history | Latest diff | List referrers | View Source